---
id: CVE-2026-52778
title: YesWiki is a wiki system written in PHP
summary: >-
  YesWiki is a wiki system written in PHP. Prior to version 4.6.6, an unsafe
  execution vulnerability exists in the Bazar form field calculator
  (CalcField.php) of YesWiki. The application attempts to sanitize user-defined
  mathematical formu…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-94
  - CWE-1333
vendor: yeswiki
product: yeswiki/yeswiki
affected:
  - yeswiki/yeswiki < 4.6.6
patched:
  - yeswiki/yeswiki 4.6.6
published: '2026-06-08'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T22:10:00.247'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-52778'
references:
  - url: >-
      https://github.com/YesWiki/yeswiki/commit/dd2bd8fb099de0d21504bda8a810693b3fcb8e52
    label: security-advisories@github.com
  - url: 'https://github.com/YesWiki/yeswiki/releases/tag/v4.6.6'
    label: security-advisories@github.com
  - url: 'https://github.com/YesWiki/yeswiki/security/advisories/GHSA-px5m-h76g-p7p8'
    label: security-advisories@github.com
  - url: 'https://github.com/YesWiki/yeswiki/security/advisories/GHSA-px5m-h76g-p7p8'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-52778'
  - url: 'https://github.com/advisories/GHSA-px5m-h76g-p7p8'
tags:
  - nvd
  - ghsa
  - composer
epss: 0.00798
epssPercentile: 0.56327
aliases:
  - GHSA-px5m-h76g-p7p8
ecosystem: composer
ingestedAt: '2026-07-09T21:52:34.658Z'
---

## Overview

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, an unsafe execution vulnerability exists in the Bazar form field calculator (CalcField.php) of YesWiki. The application attempts to sanitize user-defined mathematical formulas using a complex recursive regular expression before passing them to the PHP eval() function. This implementation is inherently flawed: it is vulnerable to Regular Expression Denial of Service (ReDoS / Stack Overflow) which can crash the server, and it creates a high-risk architecture where any logic bypass directly results in arbitrary PHP code execution. Version 4.6.6 patches the issue.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-52778)

Affected packages:

- `yeswiki/yeswiki < 4.6.6`

Patched in:

- `yeswiki/yeswiki 4.6.6`

Source: https://github.com/advisories/GHSA-px5m-h76g-p7p8
