CVE-2026-54529Medium· 5.3▾ SunlitSQLAdmin is a flexible Admin interface for SQLAlchemy models. Prior to 0.27.1, ModelView.sort_query in sqladmin/models.py accepts the attacker-controlled sortBy list-view query parameter without enforcing the configured column_sortable_l…
▾ Sunlit zone — Low / medium · no exploitation signal
impact 29.2 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake.
Exploit-prediction probability, daily snapshots since Sep 15.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.4%
0.4% → 0.4%
Last analysed / modified upstream
SQLAdmin is a flexible Admin interface for SQLAlchemy models. Prior to 0.27.1, ModelView.sort_query in sqladmin/models.py accepts the attacker-controlled sortBy list-view query parameter without enforcing the configured column_sortable_list server-side allow-list in self._sort_fields. The value is resolved with getattr and passed to relationship joins and order_by, allowing requests to sort by columns hidden from column_list and by related-model columns through dotted paths. The resulting row order forms an information-exposure oracle for unexposed values, and reversing ascending and descending order confirms their relative ordering. Pairing sortBy with searchable or filterable columns and pagination can narrow the oracle toward specific values, but exact recovery depends on the application's available fields and data. This issue is fixed in version 0.27.1.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
sqladmin < 0.27.1Patched in:
sqladmin 0.27.1Connected by shared product, vendor, weakness, or advisory.
CVE-2026-46645Medium· 4.3SQLAdmin: Authorization Bypass on `ajax_lookup`
CVE-2020-37289Low· 3.7Vyper interfaces returning integer types less than 256 bits can be manipulated if uint256 is used
CVE-2024-11042Critical· 9.1InvokeAI Arbitrary File Deletion vulnerability
CVE-2017-1000469Critical· 9.8Cobbler vulnerable to arbitrary code execution
CVE-2023-25696Critical· 9.8Apache Airflow Hive Provider Improper Input Validation vulnerability
CVE-2023-25693Critical· 9.8Apache Airflow Sqoop Provider Improper Input Validation vulnerability