---
id: CVE-2026-54851
title: >-
  WordPress Contact Form by WPForms plugin <= 2.0.3 - Cross Site Scripting (XSS)
  vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in Awesomemotive Contact Form by WPForms
  wpforms-lite allows Reflected XSS.This issue affects Contact Form by WPForms:
  from n/a through 2.…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Awesomemotive
product: wpforms-lite
affected:
  - wpforms-lite <= 2.0.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-04T14:41:52.905650Z'
published: '2026-11-04'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T15:18:56.736Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-54851'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/wpforms-lite/vulnerability/wordpress-contact-form-by-wpforms-plugin-2-0-3-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.00146
epssPercentile: 0.03852
ingestedAt: '2026-11-05T21:36:00.432Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Awesomemotive Contact Form by WPForms wpforms-lite allows Reflected XSS.This issue affects Contact Form by WPForms: from n/a through 2.0.3.

## Affected

- `wpforms-lite <= 2.0.3`

## Remediation

Update the WordPress Contact Form by WPForms plugin to the latest available version (at least 2.0.3.1).
