---
id: CVE-2026-54866
title: >-
  WordPress Razorpay Payment Button Elementor Plugin plugin <= 1.2.8 - Cross
  Site Scripting (XSS) vulnerability
summary: >-
  Unauthenticated Cross Site Scripting (XSS) in Razorpay Payment Button
  Elementor Plugin <= 1.2.8 versions.
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Razorpay
product: razorpay-payment-button-elementor
affected:
  - razorpay-payment-button-elementor >= n/a <= 1.2.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T16:15:59.239561Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T17:16:52.192Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-54866'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/razorpay-payment-button-elementor/vulnerability/wordpress-razorpay-payment-button-elementor-plugin-plugin-1-2-8-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.00243
epssPercentile: 0.15498
ingestedAt: '2026-11-01T22:02:40.976Z'
---

## Overview

Unauthenticated Cross Site Scripting (XSS) in Razorpay Payment Button Elementor Plugin <= 1.2.8 versions.

## Affected

- `razorpay-payment-button-elementor >= n/a <= 1.2.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
