---
id: CVE-2026-55549
title: Yamcs is a mission control framework
summary: >-
  Yamcs is a mission control framework. Prior to 5.9.4, Yamcs reflects an
  attacker-controlled redirect_uri parameter from GET /auth/authorize into
  yamcs-core/src/main/resources/auth/templates/authorize.html without adequate
  HTML escaping b…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N'
cwe:
  - CWE-79
vendor: yamcs
product: 'org.yamcs:yamcs-core'
affected:
  - 'org.yamcs:yamcs-core < 5.9.4'
patched:
  - 'org.yamcs:yamcs-core 5.9.4'
published: '2026-08-28'
updated: '2026-09-08'
sourceUpdated: '2026-09-08T21:08:37.320'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-55549'
references:
  - url: >-
      https://github.com/yamcs/yamcs/commit/4d47d5cdcf5d92c2c5bbbc19feada422923332e3
    label: security-advisories@github.com
  - url: 'https://github.com/yamcs/yamcs/releases/tag/yamcs-5.9.4'
    label: security-advisories@github.com
  - url: 'https://github.com/yamcs/yamcs/security/advisories/GHSA-rxpg-wjf8-qv9c'
    label: security-advisories@github.com
  - url: 'https://github.com/yamcs/yamcs/security/advisories/GHSA-rxpg-wjf8-qv9c'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://github.com/advisories/GHSA-rxpg-wjf8-qv9c'
tags:
  - nvd
  - ghsa
  - maven
  - exploit-available
epss: 0.01305
epssPercentile: 0.70382
aliases:
  - GHSA-rxpg-wjf8-qv9c
ecosystem: maven
ingestedAt: '2026-08-28T17:22:56.076Z'
exploits:
  nuclei:
    - CVE-2026-55549
  checkedAt: '2026-10-27T19:04:18.900Z'
exploitAvailable: true
---

## Overview

Yamcs is a mission control framework. Prior to 5.9.4, Yamcs reflects an attacker-controlled redirect_uri parameter from GET /auth/authorize into yamcs-core/src/main/resources/auth/templates/authorize.html without adequate HTML escaping by yamcs-core/src/main/java/org/yamcs/http/auth/AuthHandler.java and yamcs-core/src/main/java/org/yamcs/http/HandlerContext.java. A crafted authorization URL can execute JavaScript when opened by a Yamcs user. The script can access browser-held authentication material and transmit it to an attacker, enabling account compromise. This issue is fixed in version 5.9.4.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-55549)

Affected packages:

- `org.yamcs:yamcs-core < 5.9.4`

Patched in:

- `org.yamcs:yamcs-core 5.9.4`

Source: https://github.com/advisories/GHSA-rxpg-wjf8-qv9c
