---
id: CVE-2026-56385
title: Craft CMS - Authorization Bypass in assets/preview-file Endpoint
summary: >-
  Craft CMS versions >= 5.0.0-RC1, <= 5.9.13 and >= 4.0.0-RC1, <= 4.17.7 contain
  an authorization bypass in the assets/preview-file endpoint. The action does
  not enforce per-asset view authorization before returning preview content,
  allowi…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-639
vendor: craftcms
product: cms
affected:
  - cms >= 5.0.0-RC1 < 5.9.14
  - cms >= 4.0.0-RC1 < 4.17.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-06-22T12:18:03.133816Z'
published: '2026-06-21'
updated: '2026-11-08'
sourceUpdated: '2026-11-08T14:06:10.554Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-56385'
references:
  - url: 'https://github.com/craftcms/cms/security/advisories/GHSA-44px-qjjc-xrhq'
    label: GitHub Security Advisory (GHSA-44px-qjjc-xrhq)
  - url: >-
      https://github.com/craftcms/cms/commit/d30df3112220db1ffd6726a3ed11857014c7fb27
    label: >-
      https://github.com/craftcms/cms/commit/d30df3112220db1ffd6726a3ed11857014c7fb27
  - url: >-
      https://www.vulncheck.com/advisories/craft-cms-authorization-bypass-in-assets-preview-file-endpoint
    label: >-
      VulnCheck Advisory: Craft CMS - Authorization Bypass in
      assets/preview-file Endpoint
tags:
  - cve.org
epss: 0.00359
epssPercentile: 0.29908
ingestedAt: '2026-11-08T14:51:22.351Z'
---

## Overview

Craft CMS versions >= 5.0.0-RC1, <= 5.9.13 and >= 4.0.0-RC1, <= 4.17.7 contain an authorization bypass in the assets/preview-file endpoint. The action does not enforce per-asset view authorization before returning preview content, allowing an authenticated low-privileged user to supply a controlled assetId for an asset they are not permitted to view and still receive preview response data (previewHtml), including a private preview image route containing the target private assetId. Fixed in 5.9.14 and 4.17.8.

## Affected

- `cms >= 5.0.0-RC1 < 5.9.14`
- `cms >= 4.0.0-RC1 < 4.17.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
