---
id: CVE-2026-56775
title: n8n - Incorrect OAuth Scope Validation in Evaluation Test Runs Endpoints
summary: >-
  n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization
  vulnerability in three mutating evaluation test-run endpoints that authorize
  state-changing actions using the workflow:read scope instead of the
  action-appropriate workflo…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-863
vendor: n8n
product: n8n
affected:
  - n8n < 1.123.55
  - n8n >= 2.26.0 < 2.26.2
  - n8n >= 2.0.0-rc.0 < 2.25.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-07-08T14:31:14.368940Z'
published: '2026-07-08'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:15:58.761Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-56775'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-664h-gpgq-h6xx'
    label: GitHub Security Advisory (GHSA-664h-gpgq-h6xx)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-incorrect-oauth-scope-validation-in-evaluation-test-runs-endpoints
    label: >-
      VulnCheck Advisory: n8n - Incorrect OAuth Scope Validation in Evaluation
      Test Runs Endpoints
tags:
  - cve.org
epss: 0.00302
epssPercentile: 0.23068
ingestedAt: '2026-11-03T08:39:35.565Z'
---

## Overview

n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization vulnerability in three mutating evaluation test-run endpoints that authorize state-changing actions using the workflow:read scope instead of the action-appropriate workflow:execute scope. On instances using Advanced Permissions (Enterprise/Cloud) with projects and viewer roles, an authenticated user with the project:viewer role can start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only have read access to.

## Affected

- `n8n < 1.123.55`
- `n8n >= 2.26.0 < 2.26.2`
- `n8n >= 2.0.0-rc.0 < 2.25.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
