---
id: CVE-2026-56776
title: n8n - Incorrect OAuth Scope Validation in Workflow Test Run Endpoint
summary: >-
  n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization bypass in
  the POST /workflows/{workflowId}/test-runs/new endpoint, which authorizes
  access using the workflow:read scope instead of workflow:execute. An
  authenticated user…
severity: high
cvss: 7.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-863
vendor: n8n
product: n8n
affected:
  - n8n < 1.123.55
  - n8n >= 2.26.0 < 2.26.2
  - n8n >= 2.0.0-rc.0 < 2.25.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-07-09T13:38:00.557561Z'
published: '2026-07-08'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:15:59.462Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-56776'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-hv7x-3x78-gx53'
    label: GitHub Security Advisory (GHSA-hv7x-3x78-gx53)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-incorrect-oauth-scope-validation-in-workflow-test-run-endpoint
    label: >-
      VulnCheck Advisory: n8n - Incorrect OAuth Scope Validation in Workflow
      Test Run Endpoint
tags:
  - cve.org
epss: 0.00276
epssPercentile: 0.20104
ingestedAt: '2026-11-03T08:39:35.566Z'
---

## Overview

n8n before 1.123.55, 2.25.7, and 2.26.2 contains an authorization bypass in the POST /workflows/{workflowId}/test-runs/new endpoint, which authorizes access using the workflow:read scope instead of workflow:execute. An authenticated user with read-only access to a workflow can trigger a real evaluation test run, causing the workflow to execute via the internal workflow runner and resulting in unintended outbound API calls, data mutations, or other side effects in connected downstream systems. The issue primarily affects instances using the Evaluations feature where RBAC project roles grant workflow:read without workflow:execute.

## Affected

- `n8n < 1.123.55`
- `n8n >= 2.26.0 < 2.26.2`
- `n8n >= 2.0.0-rc.0 < 2.25.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
