---
id: CVE-2026-56833
title: >-
  PraisonAI Dynamic Context history and terminal tools read files outside
  configured storage via path traversal
summary: >-
  PraisonAI is a multi-agent teams system. From version 3.8.1 to before version
  4.6.59, PraisonAI's Dynamic Context module provides filesystem-backed history
  and terminal-log storage. The module also exports agent-callable tool
  factories. …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-22
  - CWE-200
vendor: MervinPraison
product: PraisonAI
affected:
  - 'PraisonAI >= 3.8.1, < 4.6.59'
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-23T17:33:09.464116Z'
published: '2026-10-23'
updated: '2026-10-23'
sourceUpdated: '2026-10-23T21:05:34.632Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-56833'
references:
  - url: >-
      https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-22cj-m4wf-fv2c
    label: >-
      https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-22cj-m4wf-fv2c
  - url: 'https://github.com/MervinPraison/PraisonAI'
tags:
  - cve.org
  - osv
  - pip
aliases:
  - GHSA-22cj-m4wf-fv2c
ecosystem: pip
patched:
  - praisonai 4.6.59
ingestedAt: '2026-07-21T19:04:55.929Z'
epss: 0.0046
epssPercentile: 0.39719
---

## Overview

PraisonAI is a multi-agent teams system. From version 3.8.1 to before version 4.6.59, PraisonAI's Dynamic Context module provides filesystem-backed history and terminal-log storage. The module also exports agent-callable tool factories. Those tools accept run_id and agent_id arguments from the tool caller. The underlying stores join those values into filesystem paths without rejecting absolute paths or .. traversal. Because run_id can be an absolute path and agent_id can contain traversal, a lower-trust prompt/user that can call these tools can read .jsonl and .log files outside the configured Dynamic Context base directory. This issue has been patched in version 4.6.59.

## Affected

- `PraisonAI >= 3.8.1, < 4.6.59`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-56833)

Affected packages:

- `praisonai >= 3.8.1, < 4.6.59`

Patched in:

- `praisonai 4.6.59`

Source: https://osv.dev/vulnerability/GHSA-22cj-m4wf-fv2c
