---
id: CVE-2026-56836
title: >-
  PraisonAI recipe serve Typer command bypasses the non-localhost authentication
  guard
summary: >-
  PraisonAI is a multi-agent teams system. From version 4.5.112 to before
  version 4.6.59, PraisonAI's installed console entrypoint is Typer-first. In
  current releases, the recipe command is registered in the Typer app and
  praisonai recipe …
severity: high
cvss: 8.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-287
  - CWE-306
  - CWE-862
vendor: MervinPraison
product: PraisonAI
affected:
  - 'PraisonAI >= 4.5.112, < 4.6.59'
published: '2026-10-23'
updated: '2026-10-23'
sourceUpdated: '2026-10-23T11:57:28.192Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-56836'
references:
  - url: >-
      https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-5qw8-f2g9-ff29
    label: >-
      https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-5qw8-f2g9-ff29
  - url: 'https://github.com/MervinPraison/PraisonAI'
tags:
  - cve.org
  - osv
  - pip
aliases:
  - GHSA-5qw8-f2g9-ff29
ecosystem: pip
patched:
  - praisonai 4.6.59
ingestedAt: '2026-07-21T19:04:56.322Z'
epss: 0.00227
epssPercentile: 0.13378
---

## Overview

PraisonAI is a multi-agent teams system. From version 4.5.112 to before version 4.6.59, PraisonAI's installed console entrypoint is Typer-first. In current releases, the recipe command is registered in the Typer app and praisonai recipe serve dispatches to the deprecated Typer command in src/praisonai/praisonai/cli/commands/recipe.py. That Typer command can start the Recipe HTTP server on a non-localhost interface with no authentication. It prints a deprecation warning, and then launches the server. Because config.auth is absent, create_app() does not attach the API-key or JWT middleware. Unauthenticated requests can then reach the recipe API and, when enabled, /admin/reload. This issue has been patched in version 4.6.59.

## Affected

- `PraisonAI >= 4.5.112, < 4.6.59`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-56836)

Affected packages:

- `praisonai >= 4.5.112, < 4.6.59`

Patched in:

- `praisonai 4.6.59`

Source: https://osv.dev/vulnerability/GHSA-5qw8-f2g9-ff29
