---
id: CVE-2026-57142
title: >-
  PraisonAI recipe workflow policy can be bypassed by declaring and
  YAML-approving dangerous tools outside TEMPLATE.yaml
summary: >-
  PraisonAI is a multi-agent teams system. From version 4.5.87 to before version
  4.6.61, PraisonAI recipe execution has a dangerous-tool policy that is
  supposed to block default-denied tools unless the caller explicitly passes
  allow_danger…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-78
  - CWE-94
  - CWE-863
vendor: MervinPraison
product: PraisonAI
affected:
  - 'PraisonAI >= 4.5.87, < 4.6.61'
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-29T13:11:25.967639Z'
exploitAvailable: true
published: '2026-10-23'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T13:12:14.267Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-57142'
references:
  - url: >-
      https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-7qw2-w5rc-37x2
    label: >-
      https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-7qw2-w5rc-37x2
  - url: 'https://github.com/MervinPraison/PraisonAI'
tags:
  - cve.org
  - exploit-available
  - osv
  - pip
epss: 0.0024
epssPercentile: 0.15197
aliases:
  - GHSA-7qw2-w5rc-37x2
ecosystem: pip
patched:
  - praisonai 4.6.61
ingestedAt: '2026-07-21T19:04:56.516Z'
---

## Overview

PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.61, PraisonAI recipe execution has a dangerous-tool policy that is supposed to block default-denied tools unless the caller explicitly passes allow_dangerous_tools=True. That policy only checks tools declared in TEMPLATE.yaml requires.tools. For steps-based recipes, the actual execution path loads workflow.yaml with YAMLWorkflowParser. That parser resolves agent-level tools: declarations and preserves top-level approve:. Workflow.start() then installs those YAML-approved tools into the approval context. As a result, an untrusted recipe can omit execute_command from TEMPLATE.yaml requires.tools, declare it in workflow.yaml agents.*.tools, and add top-level approve: [execute_command]. The caller did not set allow_dangerous_tools=True, but the recipe policy allows the recipe and the workflow approval path self-approves the critical shell tool. This issue has been patched in version 4.6.61.

## Affected

- `PraisonAI >= 4.5.87, < 4.6.61`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-57142)

Affected packages:

- `praisonai >= 4.5.87, < 4.6.61`

Patched in:

- `praisonai 4.6.61`

Source: https://osv.dev/vulnerability/GHSA-7qw2-w5rc-37x2
