---
id: CVE-2026-58188
title: >-
  Several Apache Traffic Server experimental plugins have memory-safety and
  limit-bypass errors.




  This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from
  9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.




  Users are re…
summary: >-
  Several Apache Traffic Server experimental plugins have memory-safety and
  limit-bypass errors.




  This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from
  9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.




  Users are re…
severity: high
cvss: 8.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H'
cwe:
  - CWE-787
vendor: apache
product: traffic_server
affected:
  - 'traffic_server >= 8.0.0, <= 8.1.9'
  - 'traffic_server >= 9.0.0, < 9.2.15'
  - 'traffic_server >= 10.0.0, < 10.1.4'
patched:
  - traffic_server 10.1.4
published: '2026-07-29'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T18:17:26.473'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-58188'
references:
  - url: 'https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d'
    label: security@apache.org
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-07-29T12:11:05.108556Z'
epss: 0.00772
epssPercentile: 0.55488
ingestedAt: '2026-10-01T18:55:42.330Z'
---

## Overview

Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors.



This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.



Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

## Affected

- `traffic_server >= 8.0.0, <= 8.1.9`
- `traffic_server >= 9.0.0, < 9.2.15`
- `traffic_server >= 10.0.0, < 10.1.4`

## Remediation

Upgrade past the affected range:

- `traffic_server 10.1.4`
