---
id: CVE-2026-58473
title: >-
  Cognee before 1.2.0 contains an improper access control vulnerability that
  allows unauthenticated attackers to overwrite the global LLM provider
  configuration by self-registering an account and calling the settings
  endpoint, which perfor…
summary: >-
  Cognee before 1.2.0 contains an improper access control vulnerability that
  allows unauthenticated attackers to overwrite the global LLM provider
  configuration by self-registering an account and calling the settings
  endpoint, which perfor…
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-306
  - CWE-862
vendor: topoteretes
product: cognee
affected:
  - cognee < 1.2.0
patched:
  - cognee 1.5.0
published: '2026-07-07'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:23.227'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-58473'
references:
  - url: >-
      https://github.com/topoteretes/cognee/commit/d10b1b77e2157c6238fd4d1acb1923a048991699
    label: disclosure@vulncheck.com
  - url: 'https://github.com/topoteretes/cognee/issues/3084'
    label: disclosure@vulncheck.com
  - url: 'https://github.com/topoteretes/cognee/releases/tag/v1.2.0'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/cognee-unauthorized-llm-configuration-overwrite-via-api-v1-settings
    label: disclosure@vulncheck.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-58473'
  - url: >-
      https://github.com/topoteretes/cognee/commit/10971db1b0bd97e88f96bd2a9ffb3edb7b22bcd0
  - url: >-
      https://github.com/topoteretes/cognee/commit/ebcf82412d0954f5c5018444f7eee8d96fee5113
  - url: 'https://github.com/topoteretes/cognee'
  - url: 'https://pypi.org/project/cognee'
  - url: 'https://github.com/advisories/GHSA-49f7-whx5-4256'
tags:
  - nvd
  - cve.org
  - exploit-available
  - osv
  - pip
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-07-08T14:12:35.234873Z'
epss: 0.00511
epssPercentile: 0.43375
aliases:
  - GHSA-49f7-whx5-4256
  - PYSEC-2026-3816
ecosystem: pip
ingestedAt: '2026-09-04T19:32:57.407Z'
---

## Overview

Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-58473)

Affected packages:

- `cognee < 1.5.0`

Patched in:

- `cognee 1.5.0`

Source: https://osv.dev/vulnerability/GHSA-49f7-whx5-4256
