---
id: CVE-2026-59259
title: n8n - Permission Bypass via Expression Parser Mismatch in External Secrets
summary: >-
  n8n before versions 1.123.61, 2.27.4, and 2.28.1 contains a permission bypass
  vulnerability in external secrets handling caused by a mismatch between the
  static validation check and the runtime expression engine. An authenticated
  user wi…
severity: medium
cvss: 6
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-639
vendor: n8n
product: n8n
affected:
  - n8n < 1.123.61
  - n8n >= 2.28.0 < 2.28.1
  - n8n >= 2.0.0-rc.0 < 2.27.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-07-15T18:47:30.436147Z'
published: '2026-07-15'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:16:04.961Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-59259'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-jp7m-xcgx-57qm'
    label: GitHub Security Advisory (GHSA-jp7m-xcgx-57qm)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-permission-bypass-via-expression-parser-mismatch-in-external-secrets
    label: >-
      VulnCheck Advisory: n8n - Permission Bypass via Expression Parser Mismatch
      in External Secrets
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-59259'
  - url: 'https://github.com/n8n-io/n8n/releases/tag/n8n@1.123.61'
  - url: 'https://github.com/n8n-io/n8n/releases/tag/n8n@2.27.4'
  - url: 'https://github.com/n8n-io/n8n/releases/tag/n8n@2.28.1'
  - url: 'https://github.com/advisories/GHSA-jp7m-xcgx-57qm'
tags:
  - cve.org
  - ghsa
  - npm
epss: 0.00438
epssPercentile: 0.38028
aliases:
  - GHSA-jp7m-xcgx-57qm
ecosystem: npm
patched:
  - n8n 1.123.61
  - n8n 2.28.1
  - n8n 2.27.4
ingestedAt: '2026-07-22T23:07:32.794Z'
---

## Overview

n8n before versions 1.123.61, 2.27.4, and 2.28.1 contains a permission bypass vulnerability in external secrets handling caused by a mismatch between the static validation check and the runtime expression engine. An authenticated user with credential create or update permissions but without the externalSecret:list scope can embed external secret references into credentials in forms the static validation does not detect; these references resolve at workflow execution time, exposing secret values the user is not authorized to access. This issue only affects instances where an external secrets provider is configured and Advanced Permissions are in use.

## Affected

- `n8n < 1.123.61`
- `n8n >= 2.28.0 < 2.28.1`
- `n8n >= 2.0.0-rc.0 < 2.27.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-59259)

Affected packages:

- `n8n < 1.123.61`
- `n8n >= 2.28.0, < 2.28.1`
- `n8n >= 2.0.0-rc.0, < 2.27.4`

Patched in:

- `n8n 1.123.61`
- `n8n 2.28.1`
- `n8n 2.27.4`

Source: https://github.com/advisories/GHSA-jp7m-xcgx-57qm
