---
id: CVE-2026-59837
title: >-
  A stack-based buffer overflow vulnerability in Fortinet FortiOS 7.4.0 through
  7.4.1, FortiOS 7.2 all versions, FortiOS 7.0 all versions, FortiOS 6.4 all
  versions, FortiPAM 1.8.0 through 1.8.2, FortiPAM 1.7 all versions, FortiPAM
  1.6 all …
summary: >-
  A stack-based buffer overflow vulnerability in Fortinet FortiOS 7.4.0 through
  7.4.1, FortiOS 7.2 all versions, FortiOS 7.0 all versions, FortiOS 6.4 all
  versions, FortiPAM 1.8.0 through 1.8.2, FortiPAM 1.7 all versions, FortiPAM
  1.6 all …
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C'
cvssSource: cna
cwe:
  - CWE-121
vendor: Fortinet
product: FortiOS
affected:
  - FortiOS >= 7.4.0 <= 7.4.1
  - FortiOS >= 7.2.0 <= 7.2.14
  - FortiOS >= 7.0.0 <= 7.0.19
  - FortiOS >= 6.4.0 <= 6.4.16
  - FortiProxy >= 7.4.0 <= 7.4.13
  - FortiProxy >= 7.2.0 <= 7.2.16
  - FortiPAM >= 1.8.0 <= 1.8.2
  - FortiPAM >= 1.7.0 <= 1.7.2
  - FortiPAM >= 1.6.0 <= 1.6.2
  - FortiPAM >= 1.5.0 <= 1.5.1
  - FortiPAM >= 1.4.0 <= 1.4.3
  - FortiPAM >= 1.3.0 <= 1.3.1
  - FortiPAM 1.2.0
  - FortiPAM >= 1.1.0 <= 1.1.2
  - FortiPAM >= 1.0.0 <= 1.0.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-07-14T00:00:00+00:00'
published: '2026-07-14'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T16:18:45.643Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-59837'
references:
  - url: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-148'
    label: 'https://fortiguard.fortinet.com/psirt/FG-IR-26-148'
tags:
  - cve.org
epss: 0.0067
epssPercentile: 0.51997
ingestedAt: '2026-10-15T05:52:45.995Z'
---

## Overview

A stack-based buffer overflow vulnerability in Fortinet FortiOS 7.4.0 through 7.4.1, FortiOS 7.2 all versions, FortiOS 7.0 all versions, FortiOS 6.4 all versions, FortiPAM 1.8.0 through 1.8.2, FortiPAM 1.7 all versions, FortiPAM 1.6 all versions, FortiPAM 1.5 all versions, FortiPAM 1.4 all versions, FortiPAM 1.3 all versions, FortiPAM 1.2 all versions, FortiPAM 1.1 all versions, FortiPAM 1.0 all versions, FortiProxy 7.4.0 through 7.4.13, FortiProxy 7.2 all versions may allow a privileged authenticated attacker who can bypass stack protection and ASLR to execute arbitrary code or commands via crafted HTTP requests.

## Affected

- `FortiOS >= 7.4.0 <= 7.4.1`
- `FortiOS >= 7.2.0 <= 7.2.14`
- `FortiOS >= 7.0.0 <= 7.0.19`
- `FortiOS >= 6.4.0 <= 6.4.16`
- `FortiProxy >= 7.4.0 <= 7.4.13`
- `FortiProxy >= 7.2.0 <= 7.2.16`
- `FortiPAM >= 1.8.0 <= 1.8.2`
- `FortiPAM >= 1.7.0 <= 1.7.2`
- `FortiPAM >= 1.6.0 <= 1.6.2`
- `FortiPAM >= 1.5.0 <= 1.5.1`
- `FortiPAM >= 1.4.0 <= 1.4.3`
- `FortiPAM >= 1.3.0 <= 1.3.1`
- `FortiPAM 1.2.0`
- `FortiPAM >= 1.1.0 <= 1.1.2`
- `FortiPAM >= 1.0.0 <= 1.0.3`

## Remediation

Upgrade to FortiProxy version 7.6.0 or above
Upgrade to FortiProxy version 7.4.14 or above
Upgrade to FortiPAM version 1.9.0 or above
Upgrade to FortiPAM version 1.8.3 or above
Upgrade to FortiOS version 8.0.0 or above
Upgrade to FortiOS version 7.6.0 or above
Upgrade to FortiOS version 7.4.2 or above
