---
id: CVE-2026-59898
title: >-
  io.netty/netty-codec-http: Netty: Protocol version confusion in
  netty-codec-http (WebSocket) (CVE-2026-59898)
summary: >-
  A flaw was found in netty-codec-http. The WebSocket handshaker in this
  component fails to properly validate protocol version information during the
  WebSocket upgrade process. A remote attacker can exploit this vulnerability by
  manipulating…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'
cvssSource: vendor
cwe:
  - CWE-358
  - CWE-444
vendor: Red Hat
product: OpenShift Serverless
affected:
  - cryostat 4
  - openshift_serverless
  - amq_broker 7
  - amq_clients
  - build_of_apache_camel_hawtio 4
  - build_of_apache_camel_4_for_quarkus 3
  - build_of_apache_camel_for_spring_boot 4
  - build_of_apicurio_registry 3
  - build_of_debezium 3
  - build_of_keycloak
  - build_of_quarkus
  - data_grid 8
  - enterprise_linux_ai_rhel_ai 3
  - jboss_enterprise_application_platform 7
  - jboss_enterprise_application_platform 8
  - jboss_enterprise_application_platform_expansion_pack
  - openshift_ai_rhoai
  - openshift_dev_spaces
  - satellite 6
  - single_sign_on 7
  - streams_for_apache_kafka 2
  - streams_for_apache_kafka 3
  - build_of_quarkus 3.27.4.SP3
  - build_of_quarkus 3.33.2.SP3
patched:
  - build_of_quarkus 3.27.4.SP3
  - build_of_quarkus 3.33.2.SP3
published: '2026-07-09'
updated: '2026-10-20'
sourceUpdated: '2026-10-20T04:42:49+00:00'
source: CSAF
sourceUrl: 'https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59898.json'
references:
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59898.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-59898'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2507479'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-59898'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-59898'
  - url: 'https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg'
  - url: 'https://access.redhat.com/errata/RHSA-2026:47189'
  - url: 'https://access.redhat.com/errata/RHSA-2026:47172'
  - url: 'https://github.com/netty/netty/releases/tag/netty-4.1.136.Final'
  - url: 'https://github.com/netty/netty/releases/tag/netty-4.2.16.Final'
  - url: 'https://github.com/advisories/GHSA-4mp9-239f-g9hg'
tags:
  - csaf
  - vex
  - red-hat
  - ghsa
  - maven
epss: 0.00439
epssPercentile: 0.37971
aliases:
  - GHSA-4mp9-239f-g9hg
ecosystem: maven
ingestedAt: '2026-07-22T22:06:57.704Z'
---

## Overview

A flaw was found in netty-codec-http. The WebSocket handshaker in this component fails to properly validate protocol version information during the WebSocket upgrade process. A remote attacker can exploit this vulnerability by manipulating the WebSocket handshake, leading to a bypass of security checks or the negotiation of unexpected protocol versions. This could potentially enable protocol-level attacks.

## Vendor advisories

- **RHSA-2026:47189** · Red Hat · fixed in: Red Hat build of Quarkus 3.27.4.SP3 · released 2026-07-29 · [advisory](https://access.redhat.com/errata/RHSA-2026:47189)
- **RHSA-2026:47172** · Red Hat · fixed in: Red Hat build of Quarkus 3.33.2.SP3 · released 2026-07-30 · [advisory](https://access.redhat.com/errata/RHSA-2026:47172)
- **Red Hat VEX** · Moderate · affected: Cryostat 4, OpenShift Serverless, Red Hat AMQ Broker 7, Red Hat AMQ Clients, Red Hat build of Apache Camel - HawtIO 4, Red Hat build of Apache Camel 4 for Quarkus 3, … · no fix planned: Red Hat build of Apicurio Registry 3, Red Hat Build of Keycloak, Red Hat build of Quarkus, Red Hat Data Grid 8, … · updated 2026-10-20 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-59898.json)

**io.netty/netty-codec-http: Netty: Protocol version confusion in netty-codec-http (WebSocket)** — rated Moderate by Red Hat. Released 2026-07-09, updated 2026-10-20.

Affected:

- Cryostat 4
- OpenShift Serverless
- Red Hat AMQ Broker 7
- Red Hat AMQ Clients
- Red Hat build of Apache Camel - HawtIO 4
- Red Hat build of Apache Camel 4 for Quarkus 3
- Red Hat build of Apache Camel for Spring Boot 4
- Red Hat build of Apicurio Registry 3
- Red Hat build of Debezium 3
- Red Hat Build of Keycloak
- Red Hat build of Quarkus
- Red Hat Data Grid 8
- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat OpenShift AI (RHOAI)
- Red Hat OpenShift Dev Spaces
- Red Hat Satellite 6
- Red Hat Single Sign-On 7
- streams for Apache Kafka 2
- streams for Apache Kafka 3

Fixed:

- Red Hat build of Quarkus 3.27.4.SP3
- Red Hat build of Quarkus 3.33.2.SP3

No fix planned:

- Red Hat build of Apicurio Registry 3
- Red Hat Build of Keycloak
- Red Hat build of Quarkus
- Red Hat Data Grid 8
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat Single Sign-On 7
- streams for Apache Kafka 2
- Cryostat 4
- OpenShift Serverless
- Red Hat AMQ Broker 7
- Red Hat AMQ Clients
- Red Hat build of Apache Camel - HawtIO 4
- Red Hat build of Apache Camel 4 for Quarkus 3
- Red Hat build of Apache Camel for Spring Boot 4
- Red Hat build of Debezium 3
- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat OpenShift AI (RHOAI)
- Red Hat OpenShift Dev Spaces
- Red Hat Satellite 6
- streams for Apache Kafka 3

Not affected:

- Red Hat build of Quarkus 3.27.4.SP3
- Red Hat build of Quarkus 3.33.2.SP3

## Remediation

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258 https://access.redhat.com/errata/RHSA-2026:47189
Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258 https://access.redhat.com/errata/RHSA-2026:47172

Workarounds / mitigations:

- Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

## Package advisory (CVE-2026-59898)

Affected packages:

- `io.netty:netty-codec-http >= 4.2.0.Final, <= 4.2.15.Final`
- `io.netty:netty-codec-http < 4.1.136.Final`

Patched in:

- `io.netty:netty-codec-http 4.2.16.Final`
- `io.netty:netty-codec-http 4.1.136.Final`

Source: https://github.com/advisories/GHSA-4mp9-239f-g9hg
