---
id: CVE-2026-61398
title: >-
  Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's
  UI while using Instance Reset Password functionality.


  This issue affects Apache CloudStack: from 4.15.1.0 through 4.20.3.0 and from
  4.21.0.0 through 4.22.1.0.

  …
summary: >-
  Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's
  UI while using Instance Reset Password functionality.


  This issue affects Apache CloudStack: from 4.15.1.0 through 4.20.3.0 and from
  4.21.0.0 through 4.22.1.0.

  …
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-116
vendor: apache
product: cloudstack
affected:
  - 'cloudstack >= 4.15.1.0, < 4.20.3.1'
  - 'cloudstack >= 4.21.0.0, < 4.22.1.1'
patched:
  - cloudstack 4.22.1.1
published: '2026-08-21'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:10:00.103'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-61398'
references:
  - url: 'https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc'
    label: security@apache.org
tags:
  - nvd
epss: 0.00568
epssPercentile: 0.46892
ingestedAt: '2026-10-27T18:52:09.893Z'
---

## Overview

Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Instance Reset Password functionality.

This issue affects Apache CloudStack: from 4.15.1.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

## Affected

- `cloudstack >= 4.15.1.0, < 4.20.3.1`
- `cloudstack >= 4.21.0.0, < 4.22.1.1`

## Remediation

Upgrade past the affected range:

- `cloudstack 4.22.1.1`
