---
id: CVE-2026-61400
title: >-
  Improper Neutralization of Special Elements used in a Command ('Command
  Injection') vulnerability in Apache CloudStack's run and get diagnostics
  functionality for the system VMs and virtual routers.


  An authenticated user holding the per…
summary: >-
  Improper Neutralization of Special Elements used in a Command ('Command
  Injection') vulnerability in Apache CloudStack's run and get diagnostics
  functionality for the system VMs and virtual routers.


  An authenticated user holding the per…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-77
vendor: apache
product: cloudstack
affected:
  - 'cloudstack >= 4.20.0.0, < 4.20.3.1'
  - 'cloudstack >= 4.21.0.0, < 4.22.1.1'
patched:
  - cloudstack 4.22.1.1
published: '2026-08-21'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:10:00.103'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-61400'
references:
  - url: 'https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc'
    label: security@apache.org
tags:
  - nvd
epss: 0.02907
epssPercentile: 0.86903
ingestedAt: '2026-10-27T18:52:09.894Z'
---

## Overview

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache CloudStack's run and get diagnostics functionality for the system VMs and virtual routers.

An authenticated user holding the permissions required to invoke either `getDiagnosticsData` or `runDiagnostics` can achieve arbitrary command execution on the system VM and/or Virtual Router instances, with commands running as root (or as the diagnostics-process user, at minimum). This represents a full compromise of the affected instance and, depending on network segmentation, may provide a foothold for lateral movement within the CloudStack-managed infrastructure, including access to guest network traffic handled by the compromised Virtual Router.



The getDiagnosticsData and runDiagnostics APIs are restricted to only Admin role accounts by default.


This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

## Affected

- `cloudstack >= 4.20.0.0, < 4.20.3.1`
- `cloudstack >= 4.21.0.0, < 4.22.1.1`

## Remediation

Upgrade past the affected range:

- `cloudstack 4.22.1.1`
