---
id: CVE-2026-61464
title: ImageMagick before 7.1.2-26 Heap Buffer Over-Write via X11
summary: >-
  ImageMagick before 7.1.2-26 and 6.9.13-51 contains a heap-based buffer
  over-write vulnerability that occurs when running an X11 import with a crafted
  window title, which can result in heap memory corruption and denial of
  service.
severity: low
cvss: 1.8
cvssVector: 'CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-122
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick >= 7.0.0 < 7.1.2-26
  - ImageMagick < 6.9.13-51
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-07-15T13:19:59.960415Z'
published: '2026-07-15'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:16:06.351Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-61464'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-76q6-2p6h-xjqr
    label: GitHub Security Advisory (GHSA-76q6-2p6h-xjqr)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-26-heap-buffer-over-write-via-x11
    label: >-
      VulnCheck Advisory: ImageMagick before 7.1.2-26 Heap Buffer Over-Write via
      X11
tags:
  - cve.org
epss: 0.00092
epssPercentile: 0.00484
ingestedAt: '2026-11-03T08:39:35.571Z'
---

## Overview

ImageMagick before 7.1.2-26 and 6.9.13-51 contains a heap-based buffer over-write vulnerability that occurs when running an X11 import with a crafted window title, which can result in heap memory corruption and denial of service.

## Affected

- `ImageMagick >= 7.0.0 < 7.1.2-26`
- `ImageMagick < 6.9.13-51`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
