CVE-2026-61570High· 7.5▾ TwilightMPXJ is an open source library to read and write project plans from a variety of file formats and databases. From 5.5.5 until 16.4.1, MerlinReader creates a DocumentBuilder with default settings while parsing XML from the ZTIMEINTERVALS …
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 41.3 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake.
Exploit-prediction probability, daily snapshots since Sep 23.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.5%
Last analysed / modified upstream
MPXJ is an open source library to read and write project plans from a variety of file formats and databases. From 5.5.5 until 16.4.1, MerlinReader creates a DocumentBuilder with default settings while parsing XML from the ZTIMEINTERVALS column of a Merlin project SQLite database, leaving doctype declarations and external entities enabled. A crafted database can cause the parser to read an arbitrary local file, although MPXJ's subsequent handling of the parsed XML makes disclosure of the file contents unlikely. This issue is fixed in version 16.4.1.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
net.sf.mpxj:mpxj >= 5.5.5, < 16.4.1mpxj >= 5.5.5, < 16.4.1MPXJ.Net >= 5.5.5, < 16.4.1net.sf.mpxj >= 5.5.5, < 16.4.1net.sf.mpxj-for-csharp >= 5.5.5, < 16.4.1net.sf.mpxj-for-vb >= 5.5.5, < 16.4.1mpxj >= 5.5.5, < 16.4.1Patched in:
net.sf.mpxj:mpxj 16.4.1mpxj 16.4.1MPXJ.Net 16.4.1net.sf.mpxj 16.4.1net.sf.mpxj-for-csharp 16.4.1net.sf.mpxj-for-vb 16.4.1mpxj 16.4.1Connected by shared product, vendor, weakness, or advisory.
CVE-2024-49771Medium· 5.3MPXJ has a Potential Path Traversal Vulnerability
CVE-2025-10816High· 7.3A security flaw has been discovered in Jinher OA 2.0
CVE-2025-11341High· 7.3A security flaw has been discovered in Jinher OA up to 2.0
CVE-2025-11035Medium· 6.3A vulnerability was determined in Jinher OA 2.0
CVE-2025-11140High· 7.3A vulnerability was identified in Bjskzy Zhiyou ERP up to 11.0
CVE-2022-37911Low· 3.8Due to improper restrictions on XML entities multiple vulnerabilities exist in the command line interface of ArubaOS