---
id: CVE-2026-61803
title: >-
  Frappe LMS: Client-controlled price allows paid-course / certificate purchase
  for an arbitrary amount
summary: >-
  Frappe Learning Management System (LMS) is a learning system that helps users
  structure their content. Prior to version 2.52.1, the `course/certificate
  checkout` flow accepts client-controlled pricing, allowing an authenticated
  user to c…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-502
vendor: frappe
product: lms
affected:
  - lms < 2.52.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T16:59:07.241050Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T16:59:19.940Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-61803'
references:
  - url: 'https://github.com/frappe/lms/security/advisories/GHSA-g5jj-q8m7-359c'
    label: 'https://github.com/frappe/lms/security/advisories/GHSA-g5jj-q8m7-359c'
  - url: >-
      https://github.com/frappe/lms/commit/1d04f4fd917b62f5dd4442a541280fc40a4178b4
    label: >-
      https://github.com/frappe/lms/commit/1d04f4fd917b62f5dd4442a541280fc40a4178b4
  - url: 'https://github.com/frappe/lms/tree/v2.52.1'
    label: 'https://github.com/frappe/lms/tree/v2.52.1'
tags:
  - cve.org
epss: 0.00227
epssPercentile: 0.13539
ingestedAt: '2026-11-05T16:24:31.106Z'
---

## Overview

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to version 2.52.1, the `course/certificate checkout` flow accepts client-controlled pricing, allowing an authenticated user to complete a paid-course or certificate purchase for an amount other than the actual price. This is a business-logic integrity issue; it does not expose other users' data or grant elevated privileges. This issue is fixed in version 2.52.1.

## Affected

- `lms < 2.52.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
