---
id: CVE-2026-63751
title: SurrealDB before 3.1.0 Field Permission Bypass via JSON Patch
summary: >-
  SurrealDB versions before 3.1.0 contain a field-level permission bypass
  vulnerability in JSON Patch operations that allows authenticated users to read
  protected fields. Attackers can use UPDATE PATCH with an empty from pointer in
  copy or…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-863
vendor: surrealdb
product: surrealdb
affected:
  - surrealdb < 3.1.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-07-20T15:53:10.320885Z'
published: '2026-07-20'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T15:23:48.324Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-63751'
references:
  - url: >-
      https://github.com/surrealdb/surrealdb/security/advisories/GHSA-fpxg-5xmv-922m
    label: GitHub Security Advisory (GHSA-fpxg-5xmv-922m)
  - url: >-
      https://www.vulncheck.com/advisories/surrealdb-before-field-permission-bypass-via-json-patch
    label: >-
      VulnCheck Advisory: SurrealDB before 3.1.0 Field Permission Bypass via
      JSON Patch
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-63751'
  - url: >-
      https://github.com/surrealdb/surrealdb/commit/56a7a1540d9228f82fd6284c258344e8dcb690fd
  - url: 'https://github.com/surrealdb/surrealdb'
tags:
  - cve.org
  - osv
  - rust
epss: 0.00293
epssPercentile: 0.21755
aliases:
  - GHSA-fpxg-5xmv-922m
ecosystem: rust
patched:
  - surrealdb 3.1.0
ingestedAt: '2026-09-05T19:33:49.968Z'
---

## Overview

SurrealDB versions before 3.1.0 contain a field-level permission bypass vulnerability in JSON Patch operations that allows authenticated users to read protected fields. Attackers can use UPDATE PATCH with an empty from pointer in copy or move operations to duplicate all record fields, including those restricted by field-level SELECT permissions, into attacker-chosen destination fields.

## Affected

- `surrealdb < 3.1.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-63751)

Affected packages:

- `surrealdb < 3.1.0`

Patched in:

- `surrealdb 3.1.0`

Source: https://osv.dev/vulnerability/GHSA-fpxg-5xmv-922m
