---
id: CVE-2026-65608
title: >-
  Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution
  vulnerability
summary: >-
  Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution
  vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@:
  directives by calling call_user_func_array() on attacker-influenced input,
  validating on…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-470
vendor: getgrav
product: grav
affected:
  - grav >= 1.7.0 < 2.0.9
patched:
  - getgrav/grav 2.0.9
published: '2026-07-23'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:29.700'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-65608'
references:
  - url: >-
      https://github.com/getgrav/grav/commit/fae9e1bf2c40ce0b50d0dfce647aaa1d22f98969
    label: disclosure@vulncheck.com
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-c4wf-2xxc-68qm'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/grav-before-remote-code-execution-via-flexdirectory
    label: disclosure@vulncheck.com
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-c4wf-2xxc-68qm'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-65608'
  - url: 'https://github.com/advisories/GHSA-c4wf-2xxc-68qm'
tags:
  - nvd
  - cve.org
  - exploit-available
  - ghsa
  - composer
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-07-23T18:00:17.857895Z'
epss: 0.01116
epssPercentile: 0.6589
aliases:
  - GHSA-c4wf-2xxc-68qm
ecosystem: composer
ingestedAt: '2026-09-17T17:23:30.691Z'
---

## Overview

Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@: directives by calling call_user_func_array() on attacker-influenced input, validating only that the target is callable (is_callable()) without restricting dangerous functions such as exec, system, passthru, or shell_exec. Because FlexDirectory registers this handler for every Flex directory, it bypasses the validation added to Blueprint::dynamicData() in 2.0.7 (GHSA-fj2p-qj2f-74v5). Any authenticated user with create or update permission on any Flex-based directory (Flex Users, Flex Pages, Flex Objects, or custom Flex types) can execute arbitrary shell commands on the server.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-65608)

Affected packages:

- `getgrav/grav >= 1.7.0, < 2.0.9`

Patched in:

- `getgrav/grav 2.0.9`

Source: https://github.com/advisories/GHSA-c4wf-2xxc-68qm
