---
id: CVE-2026-65613
title: >-
  Exposure of Sensitive Information to an Unauthorized Actor vulnerability in
  Apache CloudStack's Webhook module while listing and deleting deliveries.


  This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from
  4.21.0.0…
summary: >-
  Exposure of Sensitive Information to an Unauthorized Actor vulnerability in
  Apache CloudStack's Webhook module while listing and deleting deliveries.


  This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from
  4.21.0.0…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cwe:
  - CWE-200
  - CWE-284
vendor: apache
product: cloudstack
affected:
  - 'cloudstack >= 4.20.0.0, < 4.20.3.1'
  - 'cloudstack >= 4.21.0.0, < 4.22.1.1'
patched:
  - cloudstack 4.22.1.1
published: '2026-08-21'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:10:00.103'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-65613'
references:
  - url: 'https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc'
    label: security@apache.org
tags:
  - nvd
epss: 0.00452
epssPercentile: 0.39069
ingestedAt: '2026-10-27T18:52:09.897Z'
---

## Overview

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's Webhook module while listing and deleting deliveries.

This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

## Affected

- `cloudstack >= 4.20.0.0, < 4.20.3.1`
- `cloudstack >= 4.21.0.0, < 4.22.1.1`

## Remediation

Upgrade past the affected range:

- `cloudstack 4.22.1.1`
