CVE-2026-66066Critical▾ AbyssalPoC availableAction Pack is a framework for handling and responding to web requests. In versions prior to 7.2.3.2, 8.0.5.1 and 8.1.3.1, Active Storage does not disable libvips operations marked unsafe for untrusted content, allowing a crafted upload …
▾ Abyssal zone — Critical with a public exploit or in-the-wild use
impact 52.3 · likelihood 5.3 · exploitation 12
A public proof-of-concept already exists for this vulnerability — see Exploit availability below.
Public exploit / PoC code seen in 2 sources. Availability, not in-the-wild use.
Exploit-prediction probability, daily snapshots since Jul 31.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
1.7%
1.7% → 28%
7 GitHub repos · Metasploit ×1
Last analysed / modified upstream
Action Pack is a framework for handling and responding to web requests. In versions prior to 7.2.3.2, 8.0.5.1 and 8.1.3.1, Active Storage does not disable libvips operations marked unsafe for untrusted content, allowing a crafted upload to invoke such an operation. Consuming applications are affected when configured to use libvips and accept image uploads from untrusted users. An unauthenticated attacker may exploit this behavior to read arbitrary files accessible to the Rails process, including environment variables and application secrets. Exposure of credentials such as secret_key_base or external-service tokens may enable remote code execution or lateral movement. This issue has been fixed in versions 7.2.3.2, 8.0.5.1 and 8.1.3.1.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
activestorage < 7.2.3.2activestorage >= 8.0.0.beta1, < 8.0.5.1activestorage >= 8.1.0.beta1, < 8.1.3.1Patched in:
activestorage 7.2.3.2activestorage 8.0.5.1activestorage 8.1.3.1Field changes observed since this record was first indexed.
Connected by shared product, vendor, weakness, or advisory.
CVE-2022-2196Medium· 5.8A regression exists in the Linux Kernel within KVM: nVMX that allowed for speculative execution attacks. L2 can carry out Spectre v2 attacks on L1 due to L1 thinking it doesn't need retpolines or IBPB after running L2 due to KVM (L0) adv…
CVE-2026-111764High· 7.5A2A Java SDK has a fail-open default task authorization
CVE-2026-77934High· 8.8Coze Studio before 0.5.0 RCE via Unsandboxed Local Python Code Runner
CVE-2026-77936Critical· 9.8Letta through 0.16.8 Insecure Default Configuration Unauthenticated API and PostgreSQL Access
CVE-2026-109437Critical· 9.8Cognition < 0.13.0 Unauthenticated RCE via Local Shell Backend
CVE-2026-103091Critical· 9.3Insecure Default Policy and Unrestricted OIDC Enrollment in Google OSS Agent Mesh (SAM)