---
id: CVE-2026-70600
title: >-
  Electron is a framework for writing cross-platform desktop applications using
  JavaScript, HTML and CSS
summary: >-
  Electron is a framework for writing cross-platform desktop applications using
  JavaScript, HTML and CSS. Prior to 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3,
  the native autofill popup could be positioned by a cross-origin iframe outside
  th…
severity: low
cvss: 3.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N'
cwe:
  - CWE-1021
vendor: electronjs
product: electron
affected:
  - electron < 39.8.8
  - 'electron >= 40.0.0, < 40.9.0'
  - 'electron >= 41.0.0, <= 41.2.1'
  - electron = 42.0.0
patched:
  - electron 40.9.0
published: '2026-08-05'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T13:54:11.467'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-70600'
references:
  - url: >-
      https://github.com/electron/electron/security/advisories/GHSA-x8rc-wpg4-grpf
    label: security-advisories@github.com
  - url: 'https://github.com/advisories/GHSA-x8rc-wpg4-grpf'
tags:
  - nvd
  - ghsa
  - npm
epss: 0.00179
epssPercentile: 0.07371
aliases:
  - GHSA-x8rc-wpg4-grpf
ecosystem: npm
ingestedAt: '2026-08-05T15:49:00.591Z'
---

## Overview

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3, the native autofill popup could be positioned by a cross-origin iframe outside that iframe's bounds, over the embedding page's UI, enabling clickjacking or spoofing of trusted UI. Apps are only affected if they embed untrusted content in iframes within windows that also display trusted UI. Apps that do not embed untrusted third-party content are not affected. This issue is fixed in versions 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3.

## Affected

- `electron < 39.8.8`
- `electron >= 40.0.0, < 40.9.0`
- `electron >= 41.0.0, <= 41.2.1`
- `electron = 42.0.0`

## Remediation

Upgrade past the affected range:

- `electron 40.9.0`

## Package advisory (CVE-2026-70600)

Affected packages:

- `electron < 39.8.8`
- `electron >= 40.0.0-alpha.1, < 40.9.0`
- `electron >= 41.0.0-alpha.1, < 41.2.1`
- `electron >= 42.0.0-alpha.1, < 42.0.0-beta.3`

Patched in:

- `electron 39.8.8`
- `electron 40.9.1`
- `electron 41.2.1`
- `electron 42.0.0-beta.3`

Source: https://github.com/advisories/GHSA-x8rc-wpg4-grpf
