---
id: CVE-2026-70602
title: >-
  Electron is a framework for writing cross-platform desktop applications using
  JavaScript, HTML and CSS
summary: >-
  Electron is a framework for writing cross-platform desktop applications using
  JavaScript, HTML and CSS. Prior to 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3,
  extension tab and scripting APIs were not scoped to the extension's own
  session. …
severity: medium
cvss: 6.6
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N'
cwe:
  - CWE-284
vendor: electronjs
product: electron
affected:
  - electron < 39.8.8
  - 'electron >= 40.0.0, < 40.9.0'
  - 'electron >= 41.0.0, < 41.2.1'
  - electron = 42.0.0
patched:
  - electron 41.2.1
published: '2026-08-05'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T13:54:05.900'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-70602'
references:
  - url: >-
      https://github.com/electron/electron/security/advisories/GHSA-m55f-7gqj-fr98
    label: security-advisories@github.com
  - url: 'https://github.com/advisories/GHSA-m55f-7gqj-fr98'
tags:
  - nvd
  - ghsa
  - npm
epss: 0.00256
epssPercentile: 0.17212
aliases:
  - GHSA-m55f-7gqj-fr98
ecosystem: npm
ingestedAt: '2026-08-05T16:49:29.316Z'
---

## Overview

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3, extension tab and scripting APIs were not scoped to the extension's own session. A malicious or compromised extension loaded into one session could navigate, script, and read from windows belonging to a different session. Apps are only affected if they load Chrome extensions via session.loadExtension and rely on separate sessions to isolate that extension from other content. This issue is fixed in versions 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3.

## Affected

- `electron < 39.8.8`
- `electron >= 40.0.0, < 40.9.0`
- `electron >= 41.0.0, < 41.2.1`
- `electron = 42.0.0`

## Remediation

Upgrade past the affected range:

- `electron 41.2.1`

## Package advisory (CVE-2026-70602)

Affected packages:

- `electron < 39.8.8`
- `electron >= 40.0.0-alpha.1, < 40.9.0`
- `electron >= 41.0.0-alpha.1, < 41.2.1`
- `electron >= 42.0.0-alpha.1, < 42.0.0-beta.3`

Patched in:

- `electron 39.8.8`
- `electron 40.9.0`
- `electron 41.2.1`
- `electron 42.0.0-beta.3`

Source: https://github.com/advisories/GHSA-m55f-7gqj-fr98
