---
id: CVE-2026-72763
title: n8n before 1.123.67 Credential Exfiltration via Sub-Workflow
summary: >-
  n8n before 1.123.67, 2.31.5, and 2.32.1 validates credential-access only for a
  node's top-level credentials and not for credentials referenced inside an
  Execute Sub-workflow node's inline workflow JSON. A member with Editor access
  to a s…
severity: high
cvss: 7.2
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:L'
cvssSource: cna
cwe:
  - CWE-639
vendor: n8n-io
product: n8n
affected:
  - n8n < 1.123.67
  - n8n >= 2.32.0 < 2.32.1
  - n8n >= 2.0.0-rc.0 < 2.31.5
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-08-11T18:00:55.830903Z'
published: '2026-08-11'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:16:36.894Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-72763'
references:
  - url: 'https://github.com/n8n-io/n8n/security/advisories/GHSA-cj9h-qx8g-pq2g'
    label: GitHub Security Advisory (GHSA-cj9h-qx8g-pq2g)
  - url: >-
      https://www.vulncheck.com/advisories/n8n-before-credential-exfiltration-via-sub-workflow
    label: >-
      VulnCheck Advisory: n8n before 1.123.67 Credential Exfiltration via
      Sub-Workflow
tags:
  - cve.org
epss: 0.00358
epssPercentile: 0.2953
ingestedAt: '2026-11-03T08:39:35.589Z'
---

## Overview

n8n before 1.123.67, 2.31.5, and 2.32.1 validates credential-access only for a node's top-level credentials and not for credentials referenced inside an Execute Sub-workflow node's inline workflow JSON. A member with Editor access to a shared workflow (when workflow sharing is enabled) who knows a target credential's ID can reference that credential in the inline JSON; it passes save-time and runtime validation and resolves in the parent workflow's project context, allowing the attacker to use or exfiltrate credentials they are not permitted to access.

## Affected

- `n8n < 1.123.67`
- `n8n >= 2.32.0 < 2.32.1`
- `n8n >= 2.0.0-rc.0 < 2.31.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
