---
id: CVE-2026-72831
title: Grav through 2.0.11 Authentication Bypass via Flex Objects
summary: >-
  The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an
  incorrect authorization vulnerability in its Flex Objects API.
  FlexApiController::update() checks only the general Flex directory permission
  and does not apply …
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-863
vendor: getgrav
product: grav
affected:
  - grav >= 2.0.11 <= 2.0.11
  - grav-plugin-flex-objects < 1.4.7
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-08-18T01:59:11.497559Z'
exploitAvailable: true
published: '2026-08-14'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:16:51.350Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-72831'
references:
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-pc8m-jxvh-vmrc'
    label: GitHub Security Advisory (GHSA-pc8m-jxvh-vmrc)
  - url: >-
      https://github.com/getgrav/grav/commit/ad9709f865b09b68798fb1ac375b484a8cc1d892
    label: Patch Commit
  - url: >-
      https://github.com/trilbymedia/grav-plugin-flex-objects/commit/0b384f5b0e73b1ad9dd29c70185407895ea3b09f
    label: Patch Commit
  - url: >-
      https://github.com/getgrav/grav-plugin-api/commit/8071c10bc3a4743a4b8cf003dfb1644d6680c2ea
    label: Patch Commit
  - url: >-
      https://github.com/getgrav/grav-plugin-admin2/commit/a0bf26f7e5d7a98894b7cd2b8c5afe419b264e53
    label: Patch Commit
  - url: >-
      https://www.vulncheck.com/advisories/grav-through-authentication-bypass-via-flex-objects
    label: >-
      VulnCheck Advisory: Grav through 2.0.11 Authentication Bypass via Flex
      Objects
tags:
  - cve.org
  - exploit-available
epss: 0.00855
epssPercentile: 0.58379
ingestedAt: '2026-11-03T08:39:35.602Z'
---

## Overview

The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.

## Affected

- `grav >= 2.0.11 <= 2.0.11`
- `grav-plugin-flex-objects < 1.4.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
