---
id: CVE-2026-74873
title: >-
  openssl_encrypt versions before 1.4.0 expose passwords passed via the
  --password CLI argument in process listings accessible to all system users
summary: >-
  openssl_encrypt versions before 1.4.0 expose passwords passed via the
  --password CLI argument in process listings accessible to all system users.
  Attackers can read process arguments through ps aux or /proc/[pid]/cmdline to
  retrieve plai…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-214
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
patched:
  - openssl_encrypt 1.4.0
published: '2026-08-17'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:38.960'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-74873'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-h3m5-p59h-x88p
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-password-exposure-via-cli-argument
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/jahlives/openssl_encrypt/commit/e78a3666e4592f3538adaaa6be8f5f04356174db
  - url: 'https://github.com/jahlives/openssl_encrypt'
tags:
  - nvd
  - cve.org
  - osv
  - pip
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-17T14:35:09.250477Z'
epss: 0.00315
epssPercentile: 0.24581
aliases:
  - GHSA-h3m5-p59h-x88p
ecosystem: pip
ingestedAt: '2026-08-18T12:28:08.722Z'
---

## Overview

openssl_encrypt versions before 1.4.0 expose passwords passed via the --password CLI argument in process listings accessible to all system users. Attackers can read process arguments through ps aux or /proc/[pid]/cmdline to retrieve plaintext passwords and keystore passwords.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Upgrade past the affected range:

- `openssl_encrypt 1.4.0`

## Package advisory (CVE-2026-74873)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/GHSA-h3m5-p59h-x88p
