---
id: CVE-2026-74877
title: >-
  openssl_encrypt versions before 1.4.0 contain a missing ownership verification
  vulnerability in the revoke_key method that allows authenticated clients to
  revoke any other client's key
summary: >-
  openssl_encrypt versions before 1.4.0 contain a missing ownership verification
  vulnerability in the revoke_key method that allows authenticated clients to
  revoke any other client's key. Attackers can revoke arbitrary keys by
  providing a …
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-639
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
patched:
  - openssl_encrypt 1.4.0
published: '2026-08-17'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:39.583'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-74877'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-hvc7-763r-4f3h
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-missing-ownership-verification-via-revoke-key
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/jahlives/openssl_encrypt/commit/05e45f393886b5bf7e924d2dd42099a9dd37f91d
  - url: 'https://github.com/jahlives/openssl_encrypt'
tags:
  - nvd
  - cve.org
  - osv
  - pip
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-08-18T14:36:43.072806Z'
epss: 0.00451
epssPercentile: 0.39005
aliases:
  - GHSA-hvc7-763r-4f3h
ecosystem: pip
ingestedAt: '2026-08-18T12:28:09.042Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain a missing ownership verification vulnerability in the revoke_key method that allows authenticated clients to revoke any other client's key. Attackers can revoke arbitrary keys by providing a valid ML-DSA signature, bypassing the intended ownership restriction.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Upgrade past the affected range:

- `openssl_encrypt 1.4.0`

## Package advisory (CVE-2026-74877)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/GHSA-hvc7-763r-4f3h
