---
id: CVE-2026-74882
title: openssl_encrypt before 1.4.0 Insecure Default Configuration
summary: >-
  openssl_encrypt versions before 1.4.0 contain an insecure default
  configuration that trusts the entire RFC 1918 private address space in
  IntegrityProxyConfig trusted_proxies. Attackers on private networks can forge
  client certificate hea…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-345
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-18T14:37:24.226665Z'
published: '2026-08-17'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:20:55.387Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-74882'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-2592-7m3g-7fq6
    label: GitHub Security Advisory (GHSA-2592-7m3g-7fq6)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-insecure-default-configuration
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.0 Insecure Default
      Configuration
tags:
  - cve.org
  - osv
  - pip
epss: 0.00167
epssPercentile: 0.05967
aliases:
  - PYSEC-2026-3744
  - GHSA-2592-7m3g-7fq6
ecosystem: pip
patched:
  - openssl-encrypt 1.4.0
scores:
  cna: 7.5
  osv: 9.1
ingestedAt: '2026-09-02T19:31:24.709Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain an insecure default configuration that trusts the entire RFC 1918 private address space in IntegrityProxyConfig trusted_proxies. Attackers on private networks can forge client certificate headers to bypass mTLS authentication when ProxyAuth validation is relaxed or modified.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-74882)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3744
