---
id: CVE-2026-74884
title: openssl_encrypt before 1.4.0 Path Traversal via plugin_id
summary: >-
  openssl_encrypt versions before 1.4.0 contain a path traversal vulnerability
  in the _is_safe_path method where the plugin_id parameter is not sanitized
  before constructing the plugin config directory path. Attackers can declare a
  malicio…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-73
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-17T15:44:39.513593Z'
published: '2026-08-17'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:20:56.600Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-74884'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-8jpj-w975-rwv5
    label: GitHub Security Advisory (GHSA-8jpj-w975-rwv5)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-path-traversal-via-plugin-id
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.0 Path Traversal via
      plugin_id
tags:
  - cve.org
  - osv
  - pip
epss: 0.00437
epssPercentile: 0.37776
aliases:
  - PYSEC-2026-3761
  - GHSA-8jpj-w975-rwv5
ecosystem: pip
patched:
  - openssl-encrypt 1.4.0
ingestedAt: '2026-09-02T19:31:25.455Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain a path traversal vulnerability in the _is_safe_path method where the plugin_id parameter is not sanitized before constructing the plugin config directory path. Attackers can declare a malicious plugin_id containing path traversal sequences like '../' to access arbitrary directories outside the intended plugin directory.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-74884)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3761
