---
id: CVE-2026-74886
title: openssl_encrypt before 1.4.0 Plugin Import Guard Bypass
summary: >-
  openssl_encrypt versions before 1.4.0 contain a plugin sandbox bypass
  vulnerability where the PluginImportGuard blocks a different set of modules
  than the AST analyzer's DANGEROUS_MODULES set. Attackers can bypass AST
  analysis through st…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-184
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-08-17T15:23:52.639538Z'
published: '2026-08-17'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:20:57.847Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-74886'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-9pgj-v69p-q586
    label: GitHub Security Advisory (GHSA-9pgj-v69p-q586)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-plugin-import-guard-bypass
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.0 Plugin Import Guard
      Bypass
tags:
  - cve.org
  - osv
  - pip
epss: 0.00684
epssPercentile: 0.52688
aliases:
  - PYSEC-2026-3763
  - GHSA-9pgj-v69p-q586
ecosystem: pip
patched:
  - openssl-encrypt 1.4.0
ingestedAt: '2026-09-02T19:31:25.537Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain a plugin sandbox bypass vulnerability where the PluginImportGuard blocks a different set of modules than the AST analyzer's DANGEROUS_MODULES set. Attackers can bypass AST analysis through string obfuscation or encoding to import unblocked dangerous modules like sys, shutil, multiprocessing, importlib, and pickle for arbitrary code execution.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-74886)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3763
