---
id: CVE-2026-74890
title: >-
  openssl_encrypt before 1.4.0 HMAC Authentication Bypass via Environment
  Variable
summary: >-
  openssl_encrypt versions before 1.4.0 contain an authentication bypass
  vulnerability in CamelliaCipher that disables HMAC tag generation and
  verification when the PYTEST_CURRENT_TEST environment variable is set.
  Attackers with code execu…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N'
cvssSource: cna
cwe:
  - CWE-345
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-08-17T14:43:16.629569Z'
published: '2026-08-17'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:00.510Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-74890'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-rvc2-5jxq-gpcj
    label: GitHub Security Advisory (GHSA-rvc2-5jxq-gpcj)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-hmac-authentication-bypass-via-environment-variable
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.0 HMAC Authentication
      Bypass via Environment Variable
tags:
  - cve.org
  - osv
  - pip
epss: 0.00213
epssPercentile: 0.11546
aliases:
  - PYSEC-2026-3766
  - GHSA-rvc2-5jxq-gpcj
ecosystem: pip
patched:
  - openssl-encrypt 1.4.0
ingestedAt: '2026-09-02T19:31:25.660Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain an authentication bypass vulnerability in CamelliaCipher that disables HMAC tag generation and verification when the PYTEST_CURRENT_TEST environment variable is set. Attackers with code execution can set this environment variable to produce unauthenticated ciphertext and bypass integrity protection on encrypted data.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-74890)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3766
