---
id: CVE-2026-74891
title: openssl_encrypt before 1.4.0 Hardcoded Database Credentials
summary: >-
  openssl_encrypt versions before 1.4.0 contain hardcoded database credentials
  in standalone server configuration files. Attackers on the same network can
  access PostgreSQL databases using well-known default credentials to retrieve
  sensiti…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-798
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-08-17T15:30:14.388444Z'
published: '2026-08-17'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:01.125Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-74891'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-v4vm-4xf2-fhqj
    label: GitHub Security Advisory (GHSA-v4vm-4xf2-fhqj)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-hardcoded-database-credentials
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.0 Hardcoded Database
      Credentials
tags:
  - cve.org
  - osv
  - pip
epss: 0.00517
epssPercentile: 0.43819
aliases:
  - PYSEC-2026-3767
  - GHSA-v4vm-4xf2-fhqj
ecosystem: pip
patched:
  - openssl-encrypt 1.4.0
ingestedAt: '2026-09-02T19:31:25.700Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain hardcoded database credentials in standalone server configuration files. Attackers on the same network can access PostgreSQL databases using well-known default credentials to retrieve sensitive data.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-74891)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3767
