---
id: CVE-2026-74901
title: openssl_encrypt before 1.4.0 Authentication Bypass via AES-CTR Fallback
summary: >-
  openssl_encrypt versions before 1.4.0 contain an authentication bypass
  vulnerability in pqc.py where AES-GCM decryption failures trigger fallback to
  unauthenticated AES-CTR mode. Attackers can modify ciphertext in transit to
  bypass integ…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-347
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-08-17T16:00:48.847551Z'
published: '2026-08-17'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:06.550Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-74901'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-w4j7-wfgw-r52w
    label: GitHub Security Advisory (GHSA-w4j7-wfgw-r52w)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-authentication-bypass-via-aes-ctr-fallback
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.0 Authentication Bypass via
      AES-CTR Fallback
tags:
  - cve.org
  - osv
  - pip
epss: 0.00405
epssPercentile: 0.34536
aliases:
  - PYSEC-2026-3773
  - GHSA-w4j7-wfgw-r52w
ecosystem: pip
patched:
  - openssl-encrypt 1.4.0
ingestedAt: '2026-09-02T19:31:25.950Z'
---

## Overview

openssl_encrypt versions before 1.4.0 contain an authentication bypass vulnerability in pqc.py where AES-GCM decryption failures trigger fallback to unauthenticated AES-CTR mode. Attackers can modify ciphertext in transit to bypass integrity verification and perform bit-flipping attacks without detection.

## Affected

- `openssl_encrypt < 1.4.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-74901)

Affected packages:

- `openssl-encrypt < 1.4.0`

Patched in:

- `openssl-encrypt 1.4.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3773
