---
id: CVE-2026-75831
title: >-
  Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the
  audio and video media rendering through the sourceParsedownElement method
summary: >-
  Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the
  audio and video media rendering through the sourceParsedownElement method. The
  media URL fragment is concatenated unescaped into rawHtml source elements,
  allo…
severity: high
cvss: 7.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N'
cwe:
  - CWE-79
vendor: getgrav
product: grav
affected:
  - grav < 2.0.15
patched:
  - getgrav/grav 2.0.15
published: '2026-08-18'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:40.923'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-75831'
references:
  - url: >-
      https://github.com/getgrav/grav/commit/aba291a59cab29ddce491175791888d8d0b65e20
    label: disclosure@vulncheck.com
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-6qw9-4vv5-jr97'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/grav-before-stored-xss-via-audio-video-source-url
    label: disclosure@vulncheck.com
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-6qw9-4vv5-jr97'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-75831'
  - url: 'https://github.com/advisories/GHSA-6qw9-4vv5-jr97'
tags:
  - nvd
  - cve.org
  - exploit-available
  - ghsa
  - composer
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-08-18T13:55:23.651515Z'
epss: 0.0035
epssPercentile: 0.28479
aliases:
  - GHSA-6qw9-4vv5-jr97
ecosystem: composer
ingestedAt: '2026-09-08T21:11:12.279Z'
---

## Overview

Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the audio and video media rendering through the sourceParsedownElement method. The media URL fragment is concatenated unescaped into rawHtml source elements, allowing attackers to inject arbitrary HTML and JavaScript that executes in viewers' sessions.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-75831)

Affected packages:

- `getgrav/grav <= 2.0.14`

Patched in:

- `getgrav/grav 2.0.15`

Source: https://github.com/advisories/GHSA-6qw9-4vv5-jr97
