---
id: CVE-2026-75903
title: >-
  The Vulnity Security plugin for WordPress is vulnerable to authentication
  bypass in all versions up to, and including, 1.4.3 This is due to insufficient
  protection of the delegated-login pairing credential file on Nginx-based
  installatio…
summary: >-
  The Vulnity Security plugin for WordPress is vulnerable to authentication
  bypass in all versions up to, and including, 1.4.3 This is due to insufficient
  protection of the delegated-login pairing credential file on Nginx-based
  installatio…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-287
vendor: manuelgalan
product: Vulnity Security
affected:
  - vulnity_security <= 1.4.3
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:33.190'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-75903'
references:
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3719370/vulnity/trunk/includes/class-static-security.php
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3719373%40vulnity%2Ftags%2F1.4.4&old=3717813%40vulnity%2Ftags%2F1.4.3
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/5574a52f-cec8-4f79-a3a7-5c13272e5e17?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00514
epssPercentile: 0.43563
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-16T14:54:35.042782Z'
ingestedAt: '2026-10-16T08:02:23.118Z'
---

## Overview

The Vulnity Security plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 1.4.3 This is due to insufficient protection of the delegated-login pairing credential file on Nginx-based installations, where the plugin's generated server configuration snippet guards the wrong directory path. This makes it possible for unauthenticated attackers to retrieve the stored credentials, forge signed REST API requests, and log in as an administrator.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
