---
id: CVE-2026-76012
title: >-
  Photo Gallery, Sliders, Proofing and Themes <= 4.4.1 - Authenticated (Custom+)
  Local File Inclusion via Lightroom 'gallery_edit' Task property_list + Image
  Upload
summary: >-
  The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for
  WordPress is vulnerable to Remote Code Execution in all versions up to, and
  including, 4.4.1 via the legacy_render function. This is due to broken
  authorization…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-434
vendor: smub
product: 'Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery'
affected:
  - photo_gallery_sliders_proofing_and_themes_nextgen_gallery <= 4.4.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-30T17:30:30.092467Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:55.506Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-76012'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/f8b09972-4d2d-4ab3-bc12-7aba32aefd49?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/nextgen-gallery/tags/4.3.0/src/DisplayType/Controller.php#L564
  - url: >-
      https://plugins.trac.wordpress.org/browser/nextgen-gallery/tags/4.3.0/src/Lightroom/Controller.php#L45
  - url: >-
      https://plugins.trac.wordpress.org/browser/nextgen-gallery/tags/4.3.0/src/Lightroom/Controller.php#L197
  - url: >-
      https://plugins.trac.wordpress.org/browser/nextgen-gallery/tags/4.3.0/src/Lightroom/Controller.php#L1355
  - url: >-
      https://plugins.trac.wordpress.org/browser/nextgen-gallery/tags/4.3.0/src/Lightroom/Controller.php#L1465
  - url: >-
      https://plugins.trac.wordpress.org/browser/nextgen-gallery/tags/4.3.0/src/DisplayType/LegacyTemplateLocator.php#L142
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3699076/nextgen-gallery/trunk/src/DisplayType/Controller.php
tags:
  - cve.org
epss: 0.00829
epssPercentile: 0.57652
ingestedAt: '2026-11-05T16:24:31.296Z'
---

## Overview

The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.4.1 via the legacy_render function. This is due to broken authorization on the Lightroom gallery_edit endpoint combined with mass assignment of gallery path and unrestricted file upload into a registered template directory, whose extension check uses a substring match that accepts sanitized .php_ filenames as valid templates. This makes it possible for authenticated attackers, with custom-level access and above, to execute code on the server. Exploitation requires the authenticated attacker to be the stored author of at least one existing NextGEN gallery, as ownership of that gallery is the sole authorization check gating the mass-assignment and upload steps.

## Affected

- `photo_gallery_sliders_proofing_and_themes_nextgen_gallery <= 4.4.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
