---
id: CVE-2026-76266
title: >-
  In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15 on
  Linux, a local user who can run commands as the user account running Splunk
  Enterprise could cause an affected Linux package upgrade to run
  attacker-controlled op…
summary: >-
  In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15 on
  Linux, a local user who can run commands as the user account running Splunk
  Enterprise could cause an affected Linux package upgrade to run
  attacker-controlled op…
severity: high
cvss: 7.7
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H'
cwe:
  - CWE-269
vendor: splunk
product: splunk
affected:
  - 'splunk >= 9.4.0, < 9.4.15'
  - 'splunk >= 10.0.0, < 10.0.10'
  - 'splunk >= 10.2.0, < 10.2.7'
  - 'splunk >= 10.4.0, < 10.4.3'
patched:
  - splunk 10.4.3
published: '2026-10-07'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T12:22:06.520'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76266'
references:
  - url: 'https://advisory.splunk.com/advisories/SVD-2026-1001'
    label: psirt@cisco.com
tags:
  - nvd
  - cve.org
epss: 0.00154
epssPercentile: 0.04482
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-08T18:01:41.971448Z'
ingestedAt: '2026-10-07T21:54:15.093Z'
---

## Overview

In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15 on Linux, a local user who can run commands as the user account running Splunk Enterprise could cause an affected Linux package upgrade to run attacker-controlled operating-system commands with root privileges. The vulnerability is possible because the Linux package maintainer script trusts existing Splunk Enterprise installation content when it performs upgrade operations with root privileges. The vulnerability requires an affected Linux package upgrade to occur after the local user modifies the installation. The local user should not be able to elevate privileges at will.

## Affected

- `splunk >= 9.4.0, < 9.4.15`
- `splunk >= 10.0.0, < 10.0.10`
- `splunk >= 10.2.0, < 10.2.7`
- `splunk >= 10.4.0, < 10.4.3`

## Remediation

Upgrade past the affected range:

- `splunk 10.4.3`
