---
id: CVE-2026-76269
title: >-
  In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a
  user who does not hold the "admin" or "power" Splunk roles could use a
  user-controlled job identifier to access substantially all search job
  information from jobs…
summary: >-
  In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a
  user who does not hold the "admin" or "power" Splunk roles could use a
  user-controlled job identifier to access substantially all search job
  information from jobs…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-639
vendor: splunk
product: splunk
affected:
  - 'splunk >= 9.4.0, < 9.4.15'
  - 'splunk >= 10.0.0, < 10.0.10'
  - 'splunk >= 10.2.0, < 10.2.7'
  - 'splunk >= 10.4.0, < 10.4.3'
patched:
  - splunk 10.4.3
published: '2026-10-07'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T12:19:45.877'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76269'
references:
  - url: 'https://advisory.splunk.com/advisories/SVD-2026-1001'
    label: psirt@cisco.com
tags:
  - nvd
  - cve.org
epss: 0.00285
epssPercentile: 0.20904
ingestedAt: '2026-10-07T21:54:15.094Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-10T02:44:51.777404Z'
---

## Overview

In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a user who does not hold the "admin" or "power" Splunk roles could use a user-controlled job identifier to access substantially all search job information from jobs that belong to other users, including search query text, job metadata, results, and preview results, through an Application Programming Interface (API) implemented as a Representational State Transfer (REST) API. The vulnerability is possible because the REST API does not fully validate job ownership before returning search job information.

## Affected

- `splunk >= 9.4.0, < 9.4.15`
- `splunk >= 10.0.0, < 10.0.10`
- `splunk >= 10.2.0, < 10.2.7`
- `splunk >= 10.4.0, < 10.4.3`

## Remediation

Upgrade past the affected range:

- `splunk 10.4.3`
