---
id: CVE-2026-76272
title: >-
  In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a
  user who does not hold the "admin" or "power" Splunk roles could cause Splunk
  Secure Gateway to sign attacker-controlled payloads
summary: >-
  In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a
  user who does not hold the "admin" or "power" Splunk roles could cause Splunk
  Secure Gateway to sign attacker-controlled payloads. The vulnerability is
  possible b…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-862
vendor: splunk
product: splunk
affected:
  - 'splunk >= 9.4.0, < 9.4.15'
  - 'splunk >= 10.0.0, < 10.0.10'
  - 'splunk >= 10.2.0, < 10.2.7'
  - 'splunk >= 10.4.0, < 10.4.3'
  - 'splunk_secure_gateway >= 3.8.0, < 3.8.72'
  - 'splunk_secure_gateway >= 3.9.0, < 3.9.25'
  - 'splunk_secure_gateway >= 3.10.0, < 3.10.11'
patched:
  - splunk 10.4.3
  - splunk_secure_gateway 3.10.11
published: '2026-10-07'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T12:10:31.737'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76272'
references:
  - url: 'https://advisory.splunk.com/advisories/SVD-2026-1001'
    label: psirt@cisco.com
tags:
  - nvd
  - cve.org
epss: 0.00216
epssPercentile: 0.11938
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-08T15:07:40.538192Z'
ingestedAt: '2026-10-07T21:54:15.095Z'
---

## Overview

In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a user who does not hold the "admin" or "power" Splunk roles could cause Splunk Secure Gateway to sign attacker-controlled payloads. The vulnerability is possible because Splunk Secure Gateway does not verify that the user is authorized to request a signature. Splunk Secure Gateway versions below 3.10.11, 3.9.25, and 3.8.72 are also affected. For more information see Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.2/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities) in the Splunk documentation.

## Affected

- `splunk >= 9.4.0, < 9.4.15`
- `splunk >= 10.0.0, < 10.0.10`
- `splunk >= 10.2.0, < 10.2.7`
- `splunk >= 10.4.0, < 10.4.3`
- `splunk_secure_gateway >= 3.8.0, < 3.8.72`
- `splunk_secure_gateway >= 3.9.0, < 3.9.25`
- `splunk_secure_gateway >= 3.10.0, < 3.10.11`

## Remediation

Upgrade past the affected range:

- `splunk 10.4.3`
- `splunk_secure_gateway 3.10.11`
