---
id: CVE-2026-76434
title: >-
  A vulnerability in the certificate import functionality of the web-based
  management interface of Cisco ISE and Cisco ISE-PIC could allow an
  authenticated, remote attacker to read arbitrary files from the affected
  system
summary: >-
  A vulnerability in the certificate import functionality of the web-based
  management interface of Cisco ISE and Cisco ISE-PIC could allow an
  authenticated, remote attacker to read arbitrary files from the affected
  system. To exploit this …
severity: medium
cvss: 4.9
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-22
vendor: cisco
product: identity_services_engine
affected:
  - 'identity_services_engine >= 3.1.0, < 3.3.0'
  - identity_services_engine = 3.3.0
  - identity_services_engine = 3.4.0
  - identity_services_engine = 3.5.0
  - 'identity_services_engine_passive_identity_connector >= 3.1.0, < 3.3.0'
  - identity_services_engine_passive_identity_connector = 3.3.0
  - identity_services_engine_passive_identity_connector = 3.4.0
patched:
  - identity_services_engine 3.3.0
  - identity_services_engine_passive_identity_connector 3.3.0
published: '2026-09-16'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T13:14:16.233'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76434'
references:
  - url: >-
      https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-multi-traversal-WDTgYCdn
    label: psirt@cisco.com
  - url: 'https://software.cisco.com'
tags:
  - nvd
  - cve.org
  - csaf
  - vendor-advisory
  - cisco
epss: 0.00382
epssPercentile: 0.3199
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-17T16:00:22.904637Z'
ingestedAt: '2026-09-16T16:37:52.172Z'
---

## Overview

A vulnerability in the certificate import functionality of the web-based management interface of Cisco ISE and Cisco ISE-PIC could allow an authenticated, remote attacker to read arbitrary files from the affected system. To exploit this vulnerability, the attacker must have valid administrative credentials.

This vulnerability is due to insufficient validation of user-supplied input by the affected feature. An attacker could exploit this vulnerability by sending a crafted request to the web-based management interface of an affected device. A successful exploit could allow the attacker to read arbitrary files from the affected device, which could contain sensitive information.

## Affected

- `identity_services_engine >= 3.1.0, < 3.3.0`
- `identity_services_engine = 3.3.0`
- `identity_services_engine = 3.4.0`
- `identity_services_engine = 3.5.0`
- `identity_services_engine_passive_identity_connector >= 3.1.0, < 3.3.0`
- `identity_services_engine_passive_identity_connector = 3.3.0`
- `identity_services_engine_passive_identity_connector = 3.4.0`

## Remediation

Upgrade past the affected range:

- `identity_services_engine 3.3.0`
- `identity_services_engine_passive_identity_connector 3.3.0`

## Vendor advisories

- **cisco-sa-ise-multi-traversal-WDTgYCdn** · Cisco · affected: Cisco ISE Passive Identity Connector (4 versions), Cisco Identity Services Engine Software (46 versions) · updated 2026-09-16 · [advisory](https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-multi-traversal-WDTgYCdn)
