---
id: CVE-2026-76685
title: >-
  A vulnerability exists in the proxy packet processing logic of the affected
  component where it improperly processes malformed or truncated input
summary: >-
  A vulnerability exists in the proxy packet processing logic of the affected
  component where it improperly processes malformed or truncated input. An
  unauthenticated remote attacker could exploit this vulnerability by providing
  specially …
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-190
vendor: arubanetworks
product: edgeconnect_sd-wan_orchestrator
affected:
  - 'edgeconnect_sd-wan_orchestrator >= 9.4.0, < 9.4.11'
  - 'edgeconnect_sd-wan_orchestrator >= 9.5.0, < 9.5.9'
  - 'edgeconnect_sd-wan_orchestrator >= 9.6.0, < 9.6.4'
  - edgeconnect_sd-wan_orchestrator = 9.7.0
  - 'edgeconnect_operating_system >= 9.4.0.0, < 9.4.9.0'
  - 'edgeconnect_operating_system >= 9.5.0.0, < 9.5.9.0'
  - 'edgeconnect_operating_system >= 9.6.0.0, < 9.6.4.0'
  - edgeconnect_operating_system = 9.7.0.0
patched:
  - edgeconnect_sd-wan_orchestrator 9.6.4
  - edgeconnect_operating_system 9.6.4.0
published: '2026-09-15'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T13:57:43.163'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76685'
references:
  - url: >-
      https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw05135en_us&docLocale=en_US
    label: security-alert@hpe.com
tags:
  - nvd
  - cve.org
epss: 0.00668
epssPercentile: 0.51721
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-22T18:16:01.054500Z'
ingestedAt: '2026-09-15T19:42:58.826Z'
---

## Overview

A vulnerability exists in the proxy packet processing logic of the affected component where it improperly processes malformed or truncated input. An unauthenticated remote attacker could exploit this vulnerability by providing specially crafted input that triggers an integer overflow. Successful exploitation could result in a buffer overflow, potentially leading to remote code execution or denial-of-service.

## Affected

- `edgeconnect_sd-wan_orchestrator >= 9.4.0, < 9.4.11`
- `edgeconnect_sd-wan_orchestrator >= 9.5.0, < 9.5.9`
- `edgeconnect_sd-wan_orchestrator >= 9.6.0, < 9.6.4`
- `edgeconnect_sd-wan_orchestrator = 9.7.0`
- `edgeconnect_operating_system >= 9.4.0.0, < 9.4.9.0`
- `edgeconnect_operating_system >= 9.5.0.0, < 9.5.9.0`
- `edgeconnect_operating_system >= 9.6.0.0, < 9.6.4.0`
- `edgeconnect_operating_system = 9.7.0.0`

## Remediation

Upgrade past the affected range:

- `edgeconnect_sd-wan_orchestrator 9.6.4`
- `edgeconnect_operating_system 9.6.4.0`
