---
id: CVE-2026-76705
title: >-
  A buffer overflow vulnerability exists in the API endpoint of HPE Networking
  EdgeConnect SD-WAN Gateways
summary: >-
  A buffer overflow vulnerability exists in the API endpoint of HPE Networking
  EdgeConnect SD-WAN Gateways. Successful exploitation could allow an
  authenticated remote attacker with Admin privilege to execute arbitrary
  commands on the unde…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H'
cwe:
  - CWE-120
vendor: arubanetworks
product: edgeconnect_sd-wan_orchestrator
affected:
  - 'edgeconnect_sd-wan_orchestrator >= 9.4.0, < 9.4.11'
  - 'edgeconnect_sd-wan_orchestrator >= 9.5.0, < 9.5.9'
  - 'edgeconnect_sd-wan_orchestrator >= 9.6.0, < 9.6.4'
  - edgeconnect_sd-wan_orchestrator = 9.7.0
  - 'edgeconnect_operating_system >= 9.4.0.0, < 9.4.9.0'
  - 'edgeconnect_operating_system >= 9.5.0.0, < 9.5.9.0'
  - 'edgeconnect_operating_system >= 9.6.0.0, < 9.6.4.0'
  - edgeconnect_operating_system = 9.7.0.0
patched:
  - edgeconnect_sd-wan_orchestrator 9.6.4
  - edgeconnect_operating_system 9.6.4.0
published: '2026-09-15'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T13:48:38.730'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76705'
references:
  - url: >-
      https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw05135en_us&docLocale=en_US
    label: security-alert@hpe.com
tags:
  - nvd
  - cve.org
epss: 0.00543
epssPercentile: 0.45395
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-15T19:46:09.134489Z'
ingestedAt: '2026-09-15T19:42:58.822Z'
---

## Overview

A buffer overflow vulnerability exists in the API endpoint of HPE Networking EdgeConnect SD-WAN Gateways. Successful exploitation could allow an authenticated remote attacker with Admin privilege to execute arbitrary commands on the underlying operating system.

## Affected

- `edgeconnect_sd-wan_orchestrator >= 9.4.0, < 9.4.11`
- `edgeconnect_sd-wan_orchestrator >= 9.5.0, < 9.5.9`
- `edgeconnect_sd-wan_orchestrator >= 9.6.0, < 9.6.4`
- `edgeconnect_sd-wan_orchestrator = 9.7.0`
- `edgeconnect_operating_system >= 9.4.0.0, < 9.4.9.0`
- `edgeconnect_operating_system >= 9.5.0.0, < 9.5.9.0`
- `edgeconnect_operating_system >= 9.6.0.0, < 9.6.4.0`
- `edgeconnect_operating_system = 9.7.0.0`

## Remediation

Upgrade past the affected range:

- `edgeconnect_sd-wan_orchestrator 9.6.4`
- `edgeconnect_operating_system 9.6.4.0`
