---
id: CVE-2026-76846
title: >-
  Grav before 2.0.16 contains an incomplete default denylist in the Twig sandbox
  configuration that fails to block access to system configuration secrets
summary: >-
  Grav before 2.0.16 contains an incomplete default denylist in the Twig sandbox
  configuration that fails to block access to system configuration secrets.
  Attackers with page-edit permission can use config.get() or config.toArray()
  in Twig…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-522
vendor: getgrav
product: grav
affected:
  - grav < 2.0.16
patched:
  - getgrav/grav 2.0.16
published: '2026-08-25'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T15:10:00.207'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76846'
references:
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-xjw5-q542-3vmr'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/grav-before-information-disclosure-via-twig-sandbox
    label: disclosure@vulncheck.com
  - url: 'https://github.com/getgrav/grav/security/advisories/GHSA-xjw5-q542-3vmr'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-76846'
  - url: 'https://github.com/advisories/GHSA-xjw5-q542-3vmr'
tags:
  - nvd
  - cve.org
  - exploit-available
  - ghsa
  - composer
epss: 0.00305
epssPercentile: 0.23127
aliases:
  - GHSA-xjw5-q542-3vmr
ecosystem: composer
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-27T14:55:11.428296Z'
ingestedAt: '2026-09-17T20:28:02.777Z'
---

## Overview

Grav before 2.0.16 contains an incomplete default denylist in the Twig sandbox configuration that fails to block access to system configuration secrets. Attackers with page-edit permission can use config.get() or config.toArray() in Twig templates to retrieve sensitive values like system.cache.redis.password when config_access is enabled.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-76846)

Affected packages:

- `getgrav/grav <= 2.0.15`

Patched in:

- `getgrav/grav 2.0.16`

Source: https://github.com/advisories/GHSA-xjw5-q542-3vmr
