---
id: CVE-2026-77829
title: >-
  The Cooked – Recipe Management plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via [cooked-timer] Shortcode Content in all versions up
  to, and including, 1.16.1 due to insufficient input sanitization and output
  escaping…
summary: >-
  The Cooked – Recipe Management plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via [cooked-timer] Shortcode Content in all versions up
  to, and including, 1.16.1 due to insufficient input sanitization and output
  escaping…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: goratech
product: Cooked – Recipe Management
affected:
  - cooked_recipe_management <= 1.16.1
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T17:17:50.537'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-77829'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/cooked/tags/1.16.0/includes/class.cooked-shortcodes.php#L128
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/cooked/tags/1.16.0/includes/class.cooked-shortcodes.php#L155
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/cooked/tags/1.16.0/includes/class.cooked-shortcodes.php#L159
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3729711%40cooked&new=3729711%40cooked
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/0592380d-fd78-48ed-a180-299fc20a41ee?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00236
epssPercentile: 0.145
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T16:19:48.747088Z'
ingestedAt: '2026-10-16T03:57:49.272Z'
---

## Overview

The Cooked – Recipe Management plugin for WordPress is vulnerable to Stored Cross-Site Scripting via [cooked-timer] Shortcode Content in all versions up to, and including, 1.16.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
