---
id: CVE-2026-77871
title: >-
  Post Snippets <= 4.2.4 - Authenticated (Contributor+) Stored Cross-Site
  Scripting via Shortcode Attributes
summary: >-
  The Post Snippets – Custom WordPress Code Snippets Customizer plugin for
  WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode
  Attributes in all versions up to, and including, 4.2.4 due to insufficient
  input sanitization a…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: saadiqbal
product: Post Snippets – Custom WordPress Code Snippets Customizer
affected:
  - post_snippets_custom_wordpress_code_snippets_customizer <= 4.2.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:33:15.822523Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:41:51.567Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-77871'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a46c37f4-245d-423f-bdad-296fdf377ecc?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.3/src/PostSnippets/Shortcode.php#L183
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.4/src/PostSnippets/Shortcode.php#L183
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.4/src/PostSnippets/Shortcode.php#L140
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.4/src/PostSnippets/Shortcode.php#L70
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.4/src/PostSnippets/Shortcode.php#L29
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.3/src/PostSnippets/Shortcode.php#L140
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.3/src/PostSnippets/Shortcode.php#L70
  - url: >-
      https://plugins.trac.wordpress.org/browser/post-snippets/tags/4.2.3/src/PostSnippets/Shortcode.php#L29
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3759640/post-snippets/trunk/src/PostSnippets/Shortcode.php
tags:
  - cve.org
epss: 0.00241
epssPercentile: 0.15298
ingestedAt: '2026-10-28T07:06:27.108Z'
---

## Overview

The Post Snippets – Custom WordPress Code Snippets Customizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode Attributes in all versions up to, and including, 4.2.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Entity-encoded payloads such as &lt;script&gt;...&lt;/script&gt; survive WordPress's wp_kses_post on-save sanitization because kses does not decode HTML entities, and are only converted back into executable HTML tags at render time by the plugin's own shortcode filter. This requires snippet shortcodes to be enabled.

## Affected

- `post_snippets_custom_wordpress_code_snippets_customizer <= 4.2.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
