---
id: CVE-2026-78190
title: >-
  WebDyne versions from 2.014 before 3.022 for Perl reflect request parameters
  unescaped into form field values, allowing cross-site scripting
summary: >-
  WebDyne versions from 2.014 before 3.022 for Perl reflect request parameters
  unescaped into form field values, allowing cross-site scripting.


  The textfield, password_field and filefield tags fill their value attribute
  from the request p…
severity: none
cwe:
  - CWE-79
product: WebDyne
affected:
  - WebDyne >= 2.014 < 3.022
published: '2026-10-31'
updated: '2026-10-31'
sourceUpdated: '2026-10-31T14:34:14.014Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-78190'
references:
  - url: 'https://metacpan.org/release/ASPEER/WebDyne-3.022/changes'
tags:
  - cve.org
epss: 0.00239
epssPercentile: 0.15138
ingestedAt: '2026-11-05T16:24:31.548Z'
---

## Overview

WebDyne versions from 2.014 before 3.022 for Perl reflect request parameters unescaped into form field values, allowing cross-site scripting.

The textfield, password_field and filefield tags fill their value attribute from the request parameter of the same name. WEBDYNE_CGI_AUTOESCAPE, which controls escaping of these values, defaults to off. From 2.022, WebDyne::HTML::Tiny also replaced its entity_encode method with one that returns its input unchanged, so enabling WEBDYNE_CGI_AUTOESCAPE has no effect.

A remote attacker can inject script into any page using these tags through a crafted link.

## Affected

- `WebDyne >= 2.014 < 3.022`

## Remediation

Upgrade to WebDyne 3.022 or later.
